기존에 만들어진 안정인님의 스크립트가 Ubutnu 14.04 기반이라 열심히 해멘 끝에 16.04에서도 사용할 수 있게 되었다. 그래서 그 스크립트 파일을 공유하고 한다.

1
wget "https://raw.githubusercontent.com/baealex/ProgramingRecord/master/Linux/Goorm/noVNC/install.sh" -O install.sh; chmod +x install.sh; ./install.sh

기존에 사용되던 tigerVNC가 16.04에선 제대로 작동하지 않는 듯 하여 tightVNC로 변경하였다. 속도나 그런 면에서는 비등비등하다. 뭐 당연히 그렇겠지만…


하지만 잃는 것이 있다…

일단 정상적으로 동작은 하지만 약간 불안정한 모습이 보인다. 눈에 띄는 오류는 아래 사진과 같다.

오류1

오류2

해결하려고 인터넷에 검색해보니 해답은 아래와 같았다.

TightVNC may be just too old-tech to support RandR. Try my TigerVNC.

일단 제한되는게 해상도 변경인데 VNC를 사용한 목적은 눈에 보이는 결과물을 확인하는 것 뿐이니 일단은 넘어가자…


그래도 얻는 것도 있다!

얻는것

  • 기존에는 qnpbrowser인가 기억도 안나는 구동되는 브라우저를 겨우 찾아서 돌렸다. 하지만 자바스크립트 문제인지 무튼 모던 브라우저가 아니라서 레이아웃이 많이 뭉개졌다. 16.04에선 무려 firefox가 된다.
  • 아무 설정 안해줘도 한글이 잘 입력된다. 내가 좋아하는 fcitx가 기본적으로 깔려있다.


오류 해결

  • vscode 실행시 안켜지는 오류가 있는데 아래 명령어를 입력해서 해결할 수 있다.
1
sudo sed -i 's/BIG-REQUESTS/_IG-REQUESTS/' /usr/lib/x86_64-linux-gnu/libxcb.so.1
WRITTEN BY

배진오

하고싶은 건 다 하면서 사는게 목표
im@baejino.com

comments powered by Disqus